PIXI.JS + Linux Error


#1

This was mostly a me problem: I’m an outlier as far as the technology I use, but I figured I’d post it here for awareness.

I play Curve Fever using Firefox Developer Edition on Debian 10. (Linux distribution) I did a mass update of all packages at some point which caused Curve Fever to crash like this upon playing / spectating a match.

Didn’t affect me much, I just played CF on Windows. However I was doing development on a project also using PIXI.JS today and got the same error. Now knowing that it wasn’t exclusively a CF problem, I poked around for a good 25 minutes and stumbled across this. I can again play on Linux if I enter that into the browser console before joining any matches. Haven’t noticed any side effects so far.