Not fluid on retina screen but perfect on external screen



I observe a strange behavior (for a long time): on my macbook pro, when I use my native retina screen the game is much less fluid than when I use an external screen (same machine, same connection), It is not really lagging but it is a bit “saccadé” in french ( jerky, jolting, halting twitchy, according to wordreference :slight_smile: ). Still playable but much less pleasant.

I tried to set all graphical option at OFF in the game, but did not notice any change…

any ideas ?

Thanks Guys ! <3


I have the same issue with my MBpro and external screen, and I noticed when playing in the tour that my retina screen isn’t as smooth… I think it might be down to something with the screen refresh rate


I just tried to launch my browser (chrome) in “low resolution” (right click on … It seems to improve/solve the problem but it is kind of blurry and it gave me an headache :slight_smile:


If you can figure out your monitor’s refresh rate (60Hz, 120Hz, 144Hz?) then the mystery is solved :stuck_out_tongue:.

I have recently bought a mac mini myself. For macbooks/mac mini’s you can either use an hdmi or displayport (thunderbolt to displayport/hdmi) cable to connect to your monitor. To my surprise HDMI 2.0 supports 120Hz and 144Hz refresh rates. However, displayport cables transfer more data/s, resulting in better performance technically.

Whenever I use displayport as opposed to hdmi I find DP to yield better image quality as well as faster response times.


I might be wrong but I think you misunderstood my post, no ? it is working better on my external screen :wink:


Yeah that’s normal. I believe the refresh rate for retina displays is capped at 60Hz ( Thus, you need an external monitor with a refresh rate higher than 60Hz to achieve that “smoothness” you are after.

Also, remember that for retina displays it requires more computing power (making your macbook slower overall) than external non-retina displays.


The problem is more likely the high-dpi of the screen, which makes the game render at a higher resolution. You should try downscaling the game from the game video settings to render it at a lower resolution. Probably your laptop can not run the game at native resolution (4k?)

Your external monitor resolution is smaller than the native screen?