Is it just me, or is there cursing every match?



I just want to know if anyone else gets five matches straight with cursing in four of them. I know this is a community kind of thing. But people still get their meaning across with ****ing idiot. And stuff like that. Personally, I have no solution and I might just be stirring a old pot, but I was curious if it was just me who felt this way. I really like this game and there isn’t any specific kind of bulling, except on new players. But even then, I can’t help but wonder if this should be concerning… or maybe its just me and its just the same people cursing, but playing with them repeatedly.


Is there something I could do to help? So it doesn’t feel like I’m just complaining?


If you think someone is guilty because of cursing, rude chatting or anything which have offended you, you can report him/her. Just right click on his/her username and choose report.

Also, usually, I play with calm people (regulars or pros) and they haven’t done such a thing (yet). Maybe it’s just the new and not experienced players.


Okay. It wasn’t something often, but it happened recently and consistently. So I was just wondering. Thx


Yeah people are quite toxic


Sometimes telling them to stop nicely works. More often than you would think, actually, so long as you say it right. Maybe 50% of the time.


Yeah. there’s swearing. And what about it? I use and have seen every swear except the n-word. That one is discriminating. And 99.99% of the time it does not work telling someone to stop. There is tagging tho.


Add a feature to “hide chat” like the older version of curvefever. Sometimes the chat is a little too distracting.


The reason there is no more “hide chat” feature is that you can now switch to other tabs if you don’t want to see the chat ( you could choose the “Friends” tab or the “Search” tab as these 2 have no chat).

To add to what @theangelov mentioned, you can also mute the players after you report them. This can also be done by right clicking the username, but, in this case you choose the “mute” option.